Quantcast

Can't browse the tree or use "page" action

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Can't browse the tree or use "page" action

ttronslien
All of a sudden no users can add a node to a page using the Action nor can we browse any of the tree structure on the Monster Menu admin menu.

We can however add pages, change settings and use all the other features of the MM management menu.

Any suggestion what will be causing this? Even as administrator I'm experiencing this issue.

Thanks

Tove Tronslien, MSc, Informatics
Manager, Web Development Services
Lakehead University
Thunder Bay | Orillia, Ontario, Canada
[hidden email]
(807) 343-8499

---

You are currently subscribed to monster_menus as: [hidden email].

To unsubscribe click here: http://lists.middlebury.edu/u?id=685503.6b071f880fe6a965a128164e6d09ea81&n=T&l=monster_menus&o=679982

(It may be necessary to cut and paste the above URL if the line is broken)

or send a blank email to [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Can't browse the tree or use "page" action

Jay Dansand

Just a quick thought (we’ve experienced some things like this):

 

Is Thickbox still enabled/working?  Also, double-check the “Use tree browser” permission.

 

 

 

Regards,

Jay Dansand, LU '08

 

--

 ____ ____    Senior Web Application Developer

||L |||U ||   Lawrence University ITS

||__|||__||   Office:  920-832-6585

|/__\|/__\|   Fax:     920-832-7693

              E-mail:  [hidden email]

 

From: Tove Tronslien [mailto:[hidden email]]
Sent: Wednesday, August 01, 2012 2:26 PM
To: Monster Menus Development
Subject: Can't browse the tree or use "page" action

 

All of a sudden no users can add a node to a page using the Action nor can we browse any of the tree structure on the Monster Menu admin menu.

 

We can however add pages, change settings and use all the other features of the MM management menu.

 

Any suggestion what will be causing this? Even as administrator I'm experiencing this issue.

 

Thanks


Tove Tronslien, MSc, Informatics
Manager, Web Development Services
Lakehead University
Thunder Bay | Orillia, Ontario, Canada
[hidden email]
(807) 343-8499

---

You are currently subscribed to monster_menus as: [hidden email].

To unsubscribe click here: http://lists.middlebury.edu/u?id=849053.214f550f57fa54a976b5f2d087b6d379&n=T&l=monster_menus&o=679982

(It may be necessary to cut and paste the above URL if the line is broken)

or send a blank email to [hidden email]

---

You are currently subscribed to monster_menus as: [hidden email].

To unsubscribe click here: http://lists.middlebury.edu/u?id=685503.6b071f880fe6a965a128164e6d09ea81&n=T&l=monster_menus&o=679983

(It may be necessary to cut and paste the above URL if the line is broken)

or send a blank email to [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can't browse the tree or use "page" action

ttronslien
In reply to this post by ttronslien
Hi Jay,
thanks for quick reply.

Thickbox and Use tree Browser seems to be working fine as I have no problem using these when moving an existing page.

When it's no longer working are in the situations where we have migrated in content and need to assign the nodes to a drupal page. It was all working as late as yesterday.


Tove Tronslien, MSc, Informatics
Manager, Web Development Services
Lakehead University
Thunder Bay | Orillia, Ontario, Canada
[hidden email]
(807) 343-8499


On Wed, Aug 1, 2012 at 3:28 PM, Jay Dansand <[hidden email]> wrote:

Just a quick thought (we’ve experienced some things like this):

 

Is Thickbox still enabled/working?  Also, double-check the “Use tree browser” permission.

 

 

 

Regards,

Jay Dansand, LU '08

 

--

 ____ ____    Senior Web Application Developer

||L |||U ||   Lawrence University ITS

||__|||__||   Office:  <a href="tel:920-832-6585" value="+19208326585" target="_blank">920-832-6585

|/__\|/__\|   Fax:     <a href="tel:920-832-7693" value="+19208327693" target="_blank">920-832-7693

              E-mail:  [hidden email]

 

From: Tove Tronslien [mailto:[hidden email]]
Sent: Wednesday, August 01, 2012 2:26 PM
To: Monster Menus Development
Subject: Can't browse the tree or use "page" action

 

All of a sudden no users can add a node to a page using the Action nor can we browse any of the tree structure on the Monster Menu admin menu.

 

We can however add pages, change settings and use all the other features of the MM management menu.

 

Any suggestion what will be causing this? Even as administrator I'm experiencing this issue.

 

Thanks


Tove Tronslien, MSc, Informatics
Manager, Web Development Services
Lakehead University
Thunder Bay | Orillia, Ontario, Canada
[hidden email]
<a href="tel:%28807%29%20343-8499" value="+18073438499" target="_blank">(807) 343-8499

---

You are currently subscribed to monster_menus as: [hidden email].

To unsubscribe click here: http://lists.middlebury.edu/u?id=849053.214f550f57fa54a976b5f2d087b6d379&n=T&l=monster_menus&o=679982

(It may be necessary to cut and paste the above URL if the line is broken)

or send a blank email to [hidden email]

---

You are currently subscribed to monster_menus as: [hidden email].

To unsubscribe click here: http://lists.middlebury.edu/u?id=857556.923faf2f511f9d2b6990f78983c62c3e&n=T&l=monster_menus&o=679983

(It may be necessary to cut and paste the above URL if the line is broken)

or send a blank email to [hidden email]


---

You are currently subscribed to monster_menus as: [hidden email].

To unsubscribe click here: http://lists.middlebury.edu/u?id=685503.6b071f880fe6a965a128164e6d09ea81&n=T&l=monster_menus&o=679987

(It may be necessary to cut and paste the above URL if the line is broken)

or send a blank email to [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can't browse the tree or use "page" action

Dan Wilga-2
In reply to this post by ttronslien
On 8/1/12 3:40 PM, Tove Tronslien wrote:
> Hi Jay,
> thanks for quick reply.
>
> Thickbox and Use tree Browser seems to be working fine as I have no
> problem using these when moving an existing page.
>
> When it's no longer working are in the situations where we have
> migrated in content and need to assign the nodes to a drupal page. It
> was all working as late as yesterday.
Does the tree browser window appear, but just not show a tree? There is
a known bug with the tree browser that comes up in certain edge cases,
and if you're importing there's a good chance you've hit one.

When importing pages, you really should be setting the mm_catlist array
to some default value. It is required when saving nodes with MM active.
You can do something like this, to attach the nodes to the default homepage:

   $node->mm_catlist[7] = '';

Alternately, you can use SQL to add rows to mm_node2tree for all nodes
that don't currently have any page assignments. Something like this, I
think (untested):

   INSERT INTO mm_node2tree_copy (mmtid, nid) SELECT 7, n.nid FROM node
n LEFT JOIN mm_node2tree t ON t.nid = n.nid WHERE t.nid IS NULL

In both examples above, 7 is the mmtid of the default homepage. You may
want to change it to some other page.

--
Dan Wilga                                 [hidden email]
Web System Administrator/Programmer             http://www.amherst.edu
Amherst College                                      Tel: 413-542-2175
Amherst, MA  01002


---
You are currently subscribed to monster_menus as: [hidden email].
To unsubscribe click here: http://lists.middlebury.edu/u?id=685503.6b071f880fe6a965a128164e6d09ea81&n=T&l=monster_menus&o=679994
or send a blank email to [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Can't browse the tree or use "page" action

Jay Dansand
In reply to this post by ttronslien
This was actually solved - we went off-list at the end of the day to prevent inbox flooding.  It turned out that Thickbox was enabled but configured to not display on these paths:

admin*
img_assist*
node/add/*
node/*/edit

Tove reported that fixing that configuration got the functionality back.


Regards,
Jay Dansand, LU '08

--
 ____ ____    Senior Web Application Developer
||L |||U ||   Lawrence University ITS
||__|||__||   Office: 920-832-6585
|/__\|/__\|   Fax: 920-832-7693
              E-mail: [hidden email]


-----Original Message-----
From: Dan Wilga [mailto:[hidden email]]
Sent: Thursday, August 02, 2012 8:08 AM
To: Monster Menus Development
Cc: Tove Tronslien
Subject: Re: Can't browse the tree or use "page" action

On 8/1/12 3:40 PM, Tove Tronslien wrote:
> Hi Jay,
> thanks for quick reply.
>
> Thickbox and Use tree Browser seems to be working fine as I have no
> problem using these when moving an existing page.
>
> When it's no longer working are in the situations where we have
> migrated in content and need to assign the nodes to a drupal page. It
> was all working as late as yesterday.
Does the tree browser window appear, but just not show a tree? There is a known bug with the tree browser that comes up in certain edge cases, and if you're importing there's a good chance you've hit one.

When importing pages, you really should be setting the mm_catlist array to some default value. It is required when saving nodes with MM active.
You can do something like this, to attach the nodes to the default homepage:

   $node->mm_catlist[7] = '';

Alternately, you can use SQL to add rows to mm_node2tree for all nodes that don't currently have any page assignments. Something like this, I think (untested):

   INSERT INTO mm_node2tree_copy (mmtid, nid) SELECT 7, n.nid FROM node n LEFT JOIN mm_node2tree t ON t.nid = n.nid WHERE t.nid IS NULL

In both examples above, 7 is the mmtid of the default homepage. You may want to change it to some other page.

--
Dan Wilga                                 [hidden email]
Web System Administrator/Programmer             http://www.amherst.edu
Amherst College                                      Tel: 413-542-2175
Amherst, MA  01002


---
You are currently subscribed to monster_menus as: [hidden email].
To unsubscribe click here: http://lists.middlebury.edu/u?id=849053.214f550f57fa54a976b5f2d087b6d379&n=T&l=monster_menus&o=679994
or send a blank email to [hidden email]

---
You are currently subscribed to monster_menus as: [hidden email].
To unsubscribe click here: http://lists.middlebury.edu/u?id=685503.6b071f880fe6a965a128164e6d09ea81&n=T&l=monster_menus&o=679995
or send a blank email to [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can't browse the tree or use "page" action

ttronslien
In reply to this post by ttronslien
Thanks Jay for  the update.

And thanks Dan for providing the additional information - although the problem was solved - the added information is useful to us.

Tove Tronslien, MSc, Informatics
Manager, Web Development Services
Lakehead University
Thunder Bay | Orillia, Ontario, Canada
[hidden email]
(807) 343-8499


On Thu, Aug 2, 2012 at 9:12 AM, Jay Dansand <[hidden email]> wrote:
This was actually solved - we went off-list at the end of the day to prevent inbox flooding.  It turned out that Thickbox was enabled but configured to not display on these paths:

admin*
img_assist*
node/add/*
node/*/edit

Tove reported that fixing that configuration got the functionality back.


Regards,
Jay Dansand, LU '08

--
 ____ ____    Senior Web Application Developer
||L |||U ||   Lawrence University ITS
||__|||__||   Office:   <a href="tel:920-832-6585" value="+19208326585">920-832-6585
|/__\|/__\|   Fax:      <a href="tel:920-832-7693" value="+19208327693">920-832-7693
              E-mail:   [hidden email]


-----Original Message-----
From: Dan Wilga [mailto:[hidden email]]
Sent: Thursday, August 02, 2012 8:08 AM
To: Monster Menus Development
Cc: Tove Tronslien
Subject: Re: Can't browse the tree or use "page" action

On 8/1/12 3:40 PM, Tove Tronslien wrote:
> Hi Jay,
> thanks for quick reply.
>
> Thickbox and Use tree Browser seems to be working fine as I have no
> problem using these when moving an existing page.
>
> When it's no longer working are in the situations where we have
> migrated in content and need to assign the nodes to a drupal page. It
> was all working as late as yesterday.
Does the tree browser window appear, but just not show a tree? There is a known bug with the tree browser that comes up in certain edge cases, and if you're importing there's a good chance you've hit one.

When importing pages, you really should be setting the mm_catlist array to some default value. It is required when saving nodes with MM active.
You can do something like this, to attach the nodes to the default homepage:

   $node->mm_catlist[7] = '';

Alternately, you can use SQL to add rows to mm_node2tree for all nodes that don't currently have any page assignments. Something like this, I think (untested):

   INSERT INTO mm_node2tree_copy (mmtid, nid) SELECT 7, n.nid FROM node n LEFT JOIN mm_node2tree t ON t.nid = n.nid WHERE t.nid IS NULL

In both examples above, 7 is the mmtid of the default homepage. You may want to change it to some other page.

--
Dan Wilga                                 [hidden email]
Web System Administrator/Programmer             http://www.amherst.edu
Amherst College                                      Tel: <a href="tel:413-542-2175" value="+14135422175">413-542-2175
Amherst, MA  01002


---
You are currently subscribed to monster_menus as: [hidden email].
To unsubscribe click here: http://lists.middlebury.edu/u?id=849053.214f550f57fa54a976b5f2d087b6d379&n=T&l=monster_menus&o=679994
or send a blank email to [hidden email]

---
You are currently subscribed to monster_menus as: [hidden email].
To unsubscribe click here: http://lists.middlebury.edu/u?id=857556.923faf2f511f9d2b6990f78983c62c3e&n=T&l=monster_menus&o=679995
or send a blank email to [hidden email]

---

You are currently subscribed to monster_menus as: [hidden email].

To unsubscribe click here: http://lists.middlebury.edu/u?id=685503.6b071f880fe6a965a128164e6d09ea81&n=T&l=monster_menus&o=679996

(It may be necessary to cut and paste the above URL if the line is broken)

or send a blank email to [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can't browse the tree or use "page" action

Dan Wilga-2
In reply to this post by ttronslien
On 8/2/12 9:12 AM, Jay Dansand wrote:
> This was actually solved - we went off-list at the end of the day to prevent inbox flooding.  It turned out that Thickbox was enabled but configured to not display on these paths:
>
> admin*
> img_assist*
> node/add/*
> node/*/edit
>
Ah, yes. I had changed the default value for that variable in our
version of the thickbox code, but I'm not sure that's the version that
is referred to on drupal.org. One more reason to get rid of the TB
dependency ASAP :-).

--
Dan Wilga                                 [hidden email]
Web System Administrator/Programmer             http://www.amherst.edu
Amherst College                                      Tel: 413-542-2175
Amherst, MA  01002


---
You are currently subscribed to monster_menus as: [hidden email].
To unsubscribe click here: http://lists.middlebury.edu/u?id=685503.6b071f880fe6a965a128164e6d09ea81&n=T&l=monster_menus&o=679997
or send a blank email to [hidden email]
Loading...